• Home
  • Sage
  • The SmartPosting Service On The Server Is Not Running & Unable to Get Restarted

The SmartPosting Service On The Server Is Not Running & Unable to Get Restarted

You can face error messages on your desktop with your SmartPosting application like:

“The Smartposting Service On The Server [SERVER NAME] Is Not Running So Cannot Be Restarted.”

 SmartPosting Service Not Running Error

Or your program fails to install alternatively you can face login issues stating SMART posting has crashed and server administrator requires action.

How to Resolve the Problem?

  1. First, ensure the Sage 50 is closed.
  2. Go to the server, ascertain the below-listed 3 files installed into your program path. 
  • SmartPostingService20XX.exe
  • SmartPostingService20XX.exe.config
  • SmartPostingInterop.dll
  1. Next, copy the below command line into your Notepad:

 sc create “Sage 50 Smart Posting 2019” start= auto binPath= “C:\Program Files\Sage50\SmartPostingService2019.exe” DisplayName= “Sage 50 SmartPosting 2019”

  1. Within your Notepad, update your binPath to exactly match the program path.
  2. If a user uses a different release, then you need to change the year 2019 in all three places to the right Release Year
  3. Select Start and Run
  4. Enter cmd in the Open field box and select OK.
  5. Now, paste the command line you generated in step 3 into your DOS prompt box and press enter
  6. SUCCESS will display on the screen
  7. Choose Start, Run and enter services.msc
  8. Under the list, right-click on the Sage 50 installed SmartPosting 20XX and select the Start
  9. Verify your SmartPosting service is now actively running

 

 

Facing Issues? icon Submit Your Queries

Can't find what you're looking for?

Please reach out to [email protected] and we will happily answer any question you may have.

Talk To Our Technical Expert